Global routing issue in Level3
Incident Report for Egnyte
Resolved
We have been notified that the issues reported by Level 3 have been resolved.
Posted Mar 15, 2017 - 22:52 UTC
Identified
The global Internet provider Level3 is experiencing issues. This might affect some of our customers' experience.
Posted Mar 15, 2017 - 16:14 UTC