Network Issues (US-East Coast)
Incident Report for Egnyte
Resolved
We have identified a Denial-of-Service attack to our services for customers in the East Coast. We have mitigated the issues as soon as they were detected however some customers might have noticed slow share link downloads.

Postmortem: The distributed nature of a DDoS attack makes it significantly more powerful, as well as harder to identify and block its source. We have identified 3 different attacks at 3 different times that we mitigated as soon as they got detected. During this time some customers might have experienced slow share links. We have blocked the sources of these attacks and we are continuously monitoring the traffic. Also we are implementing a new self-healing patch that will prevent these issues in the future. The patch will be released in the next 48 hours. While we never recorded a downtime during this incident we realized that slow share links occurred for about 45 minutes between DDoS attacks. If you have experienced any slow share links please contact our Support team.
Posted Nov 28, 2017 - 12:00 UTC