All Systems Operational
Collaboration Operational
Web UI Operational
Preview Operational
Reports Operational
Search Operational
WebDAV Operational
Desktop App Operational
Mobile Operational
Sync Operational
FTP/SFTP Operational
Email Notifications Operational
Public APIs and Integrations Operational
Registrations ? Operational
TFA Operational
Login Operational
Security and Governance Operational
UI Operational
Core Content Classification Operational
Advanced Content Classification Operational
Anomaly Detection Operational
Issue Processing Operational
Content Lifecycle Operational
Email Alerts Operational
Other Services Operational
Website Operational
Email Operational
Network Operational
Migration Services Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Scheduled Maintenance
To ensure the stability and reliability of our services, various maintenance tasks will be performed. As a result, customers may experience service interruptions during the maintenance period. The services might encounter interruptions of up to 5 minutes in US West Coast, US East Coast and European Region.

Please accept our apologies for any inconvenience this may cause and we appreciate your patience during this time. Our team will work to minimize the impact on our users and complete the maintenance as quickly and efficiently as possible.

We will continue to provide updates on this page as the maintenance progresses. If you have any questions or concerns, please do not hesitate to reach out to our support team. Thank you for your understanding.

Posted on Apr 25, 2024 - 16:30 UTC
Past Incidents
May 2, 2024

No incidents reported today.

May 1, 2024

No incidents reported.

Apr 30, 2024
Resolved - Our team confirmed that everything should be back to normal now. If you continue to experience any issues, please reach out to our support team for further assistance. We apologize for any inconvenience this may have caused and appreciate your patience during this time.
Apr 30, 18:10 UTC
Monitoring - We have implemented a fix for the issue and are currently monitoring the results. If you are still experiencing any problems, please contact our support team.
Apr 30, 17:59 UTC
Identified - Our team has identified the issue and we're actively working on a fix. We will provide an update within the next 30 minutes.
Apr 30, 17:53 UTC
Investigating - We are currently investigating issues with our Public API and integration service in the US-East Coast & US-West Coast regions. The MS co-editing and Egnyte app store is currently not accessible & our team is actively working on a resolution, and we will provide an update in the next 30 minutes. We apologize for any disruption this may cause and appreciate your patience as we work to restore normal service.
Apr 30, 17:28 UTC
Apr 29, 2024
Resolved - This incident has been resolved.
Apr 29, 17:57 UTC
Monitoring - We have implemented a fix for the issue and are currently monitoring the results. If you are still experiencing any problems, please contact our support team.
Apr 29, 17:51 UTC
Update - We are continuing to investigate this issue.
Apr 29, 17:40 UTC
Investigating - We are currently investigating issues with our Secure & Govern service in the US region. Our team is actively working on a resolution, and we will provide an update in the next 30 minutes. We apologize for any disruption this may cause and appreciate your patience as we work to restore normal service.
Apr 29, 17:39 UTC
Apr 28, 2024

No incidents reported.

Apr 27, 2024
Completed - The scheduled maintenance has been completed.
Apr 27, 07:00 UTC
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 27, 04:00 UTC
Scheduled - To ensure the stability and reliability of our services, various maintenance tasks will be performed. As a result, customers may experience service interruptions during the maintenance period. The services might encounter interruptions of up to 15 minutes in US East Coast and European region, and 20 minutes in US West Coast.

Customers using the Sharepoint Integration will experience an interruption of up to 8 hours.

Please accept our apologies for any inconvenience this may cause and we appreciate your patience during this time. Our team will work to minimize the impact on our users and complete the maintenance as quickly and efficiently as possible.

We will continue to provide updates on this page as the maintenance progresses. If you have any questions or concerns, please do not hesitate to reach out to our support team. Thank you for your understanding.

Apr 24, 15:33 UTC
Apr 26, 2024

No incidents reported.

Apr 25, 2024

No incidents reported.

Apr 24, 2024

No incidents reported.

Apr 23, 2024

No incidents reported.

Apr 22, 2024

No incidents reported.

Apr 21, 2024

No incidents reported.

Apr 20, 2024
Completed - The scheduled maintenance has been completed.
Apr 20, 07:00 UTC
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 20, 04:00 UTC
Scheduled - To ensure the stability and reliability of our services, various maintenance tasks will be performed. As a result, customers may experience service interruptions during the maintenance period. The services might encounter interruptions of up to 105 minutes in US East Coast Region and up to 75 minutes in US West Coast.
Please accept our apologies for any inconvenience this may cause and we appreciate your patience during this time. Our team will work to minimize the impact on our users and complete the maintenance as quickly and efficiently as possible.
We will continue to provide updates on this page as the maintenance progresses. If you have any questions or concerns, please do not hesitate to reach out to our support team. Thank you for your understanding.

Apr 12, 15:40 UTC
Apr 19, 2024

No incidents reported.

Apr 18, 2024

No incidents reported.