Intermittent issues with Public APIs and Integrations in multiple regions

Incident Report for Egnyte Platform

Resolved

This incident has been resolved.
Posted Aug 04, 2025 - 22:44 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 04, 2025 - 21:55 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 04, 2025 - 19:38 UTC

Investigating

We are currently investigating issues with Public APIs and Integrations in the European and US regions. Our team is actively working on a resolution, and we will provide an update in the next 60 minutes. We apologise for any disruption this may cause and appreciate your patience as we work to restore normal service.
Posted Aug 04, 2025 - 19:09 UTC
This incident affected: Security and Governance (Public APIs and Integrations).